Phone City Magazine

 Breaking News
សេចក្តីជូនដំណឹង : សម្រាប់ការអញ្ជើញចូលរួមកម្មវិធីសម្ពោធនាៗ សូមទំនាក់ទំនងទៅកាន់លេខ 010 97 35 45។ ទំនាក់ទំនងផ្សាយពាណិជ្ជកម្មៈ 010 97 35 45

កំហុសឆ្គងថ្មីនៅលើ WordPress អនុញ្ញាតអោយអ្នកវាយប្រហារពីចម្ងាយដែលគ្មានសិទ្ធិផ្តល់អោយហេគទៅលើគេហទំព័រជាច្រើន

March 16
08:47 pm 2019
Like and Share this page:

ប្រសិនបើមានហេតុផលមួយចំនួនគេហទំព័រដែលមានមូលដ្ឋាននៅលើប្លក Wordpress របស់អ្នកមិន ទាន់ធ្វើបច្ចុប្បន្នភាពដោយស្វ័យប្រវត្តិទៅកំណែថ្មីបំផុត 5.1.1 វាផ្ដល់អនុសាសន៍ឱ្យដំឡើងវាភ្លាមៗមុន ពេលដែលពួកហេគឃរ័ អាចទាញយកផលប្រយោជន៍ពីភាពងាយរងគ្រោះដែលបញ្ចេញថ្មីដើម្បី hack គេហទំព័ររបស់អ្នក។

image

លោក Simon Scannell អ្នកស្រាវជ្រាវម្នាក់នៅក្រុមហ៊ុន RIPS Technologies GmbH ដែលធ្លាប់រាយការណ៍ពីភាពងាយរងគ្រោះសំខាន់ៗជាច្រើននៅក្នុងប្លក Wordpress រកឃើញ កំហុសថ្មីនៅក្នុងកម្មវិធីគ្រប់គ្រងមាតិកា (CMS) ដែលអាចនាំឱ្យមានការវាយប្រហារកូដពីចម្ងាយ។ គុណវិបត្តិនេះកើតឡើងពីការស្នើសុំពាក្យឆ្លងកាត់ (CSRF) នៅក្នុងផ្នែកអត្ថាធិប្បាយរបស់ Wordpress ដែលជាស្នូលមួយរបស់វាភ្ជាប់មកជាមួយតាមលំនាំដើមហើយប៉ះពាល់ដល់ការដំឡើងទាំងអស់មុន ជំនាន់ 5.1.1។

មិនដូចការវាយប្រហារមុនៗ ដែលចងក្រងជាឯកសារប្រឆាំងនឹង WordPress ទេ ការក្ស័យធនថ្មីនេះ អនុញ្ញាតឱ្យអ្នកវាយប្រហារពីចម្ងាយ "មិនបានផ្ទៀងផ្ទាត់ភាពត្រឹមត្រូវ" និងទទួលប្រតិបត្តិកូដពីចម្ងាយ នៅលើគេហទំពរ័ WordPress ងាយរងគ្រោះ។ លោក Scannell មានប្រសាសន៍ថា "ការគិតថាការ អត្ថាធិប្បាយគឺជាលក្ខណៈសំខាន់នៃប្លុកនិងបើកដំណើរការតាមលំនាំដើម ដែលភាពងាយរងគ្រោះ នោះប៉ះពាល់ដល់គេហទំព័ររាប់លាន។

ការទាញយកផលដែលបង្ហាញដោយ Scannell ពឹងផ្អែកលើបញ្ហាជាច្រើនរួមមាន:

  • Wordpress មិនប្រើសុពលភាព CSRF ទេ នៅពេលអ្នកប្រើប្រកាសមតិយោបល់ថ្មីដែល អនុញ្ញាតឱ្យអ្នកវាយប្រហារប្រកាសមតិក្នុងនាមអ្នកគ្រប់គ្រង។

  • មតិយោបល់ដែលបង្ហោះដោយគណនីអ្នកគ្រប់គ្រងមិនមានសុវត្ថិភាពហើយអាចរាប់បញ្ចូល ទាំងស្លាក HTML បំពាន សូម្បីតែស្លាក SCRIPT។

  • ផ្នែកខាងមុខ Wordpress មិនបានការពារដោយ X-Frame-Options header ដែលអនុញ្ញាតឱ្យ អ្នកវាយប្រហារបើកគេហទំព័រដែលបានកំណត់គោលដៅនៅក្នុង iFrame ដែលលាក់ពី គេហទំពរ័ដែលគ្រប់គ្រងដោយអ្នកវាយប្រហារ។

ដោយរួមបញ្ចូលគ្នានូវបញ្ហាទាំងអស់នេះអ្នកវាយប្រហារអាចចាក់បញ្ចូលទិន្នន័យ XSS ផ្ទុកដោយ ស្ងៀមស្ងាត់ទៅក្នុងគេហទំព័រគោលដៅដោយគ្រាន់តែឆបោកអ្នកគ្រប់គ្រងចូលទៅមើលគេហទំព័រ ដែលមានកូដទាញយក (exploit code)។

យោងទៅតាមអ្នកស្រាវជ្រាវអ្នកវាយប្រហារអាចគ្រប់គ្រងលើគេហទំពរ័ WordPress គោលដៅពី ចម្ងាយដោយចាក់បញ្ចូលទិន្នន័យ XSS ដែលអាចកែប្រែប្លង់ Wordpress template ដោយផ្ទាល់ដើម្បី រួមបញ្ចូល PHP backdoor ដែលមានគ្រោះថ្នាក់ទាំងអស់ក្នុងមួយជំហានដោយគ្មានអ្នកគ្រប់គ្រងកត់ សំគាល់។ បន្ទាប់ពី Scannell រាយការណ៍ភាពងាយរងគ្រោះនេះកាលពីខែតុលាឆ្នាំមុនក្រុមការងារ WordPress ព្យាយាមកាត់បន្ថយបញ្ហានេះដោយការណែនាំថ្មីមួយទៀតសម្រាប់អ្នកគ្រប់គ្រងនៅក្នុង សំណុំបែបបទផ្តល់មតិយោបល់ជំនួសឱ្យការការពារ CSRF។ ទោះជាយ៉ាងណាក៏ដោយ Scannell ក៏អាចបដិសេធផងដែរបន្ទាប់ពីក្រុម CMS ចេញផ្សាយ WordPress 5.1.1 ជាមួយនឹងបំណែកដែល មានស្ថេរភាពកាលពីថ្ងៃពុធ។

ចាប់តាំងពី WordPress ដំឡើងការធ្វើបច្ចុប្បន្នភាពសុវត្ថិភាពដោយ ស្វ័យប្រវត្តិតាមលំនាំដើមអ្នកគួរតែដំណើរការកំណែចុងក្រោយនៃកម្មវិធីគ្រប់គ្រងមាតិកា។ ទោះជាយ៉ាងណាក៏ដោយប្រសិនបើការធ្វើបច្ចុប្បន្នភាពដោយស្វ័យប្រវត្តិនូវផ្នែកគ្រប់គ្រងរបស់អ្នកត្រូវបានបិទអ្នកត្រូវបានគេណែនាំឱ្យបិទមតិយោបល់ (disable comments) ជាបណ្ដោះអាសន្ន ហើយ ចេញពី administrator របស់អ្នករហូតដល់ការដំឡើងផ្នែកសុវត្ថិភាពត្រូវបានតំឡើង៕

Like and Share this page:

Related Posts


Comments

ជួយគាំទ្រយើងនៅក្នុង Facebook

ព័ត៌មានពេញ​និយម​ប្រចាំ​សប្ដាហ៍

ទិញលក់ ទំនិញ ពេញ​និយម​ប្រចាំ​សប្ដាហ៍

ចំនួនអ្នកចូលទស្សនា

Today : 14191
Yesterday : 17630
This Month : 444810
Last Month : 558892
Total Visitor : 23318368